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1 Introduction

The modeling framework FlexSem is a fast, flexible and user friendly tool specifically targeted to-
wards scientific and management challenges of the complex biogeochemical processes in coastal zone
ecosystems. Please refer to the web site https://marweb.bios.au.dk/FlexSem/ for publications, ex-
amples of use, downloads and more.

Questions? please contact Janus Larsen janus@bios.au.dk
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2 Mesh

The computational mesh is defined in a tab seperated text file. The first line gives the number of
nodes, the number of elements and optionally the number of Voronoi points (always equal to number
of elements). All nodes and elements are indexed starting with zero.
The following [number of nodes] lines gives the x,y coordinates of the nodes and in the third col-
umn optionally the node type. Supported node types are: 0=internal, 99=land bnd, (>0<99)=open
boundary.
Then follows one line per element, each line giving the node number of the nodes that makes up the
element (polygon) in counter clockwise order (the connectivity).
If the number of voronoi points are given in the header, coordinates of voronoi points for each el-
ement is given in after the element connectivity. Notice that all vononoi points must be inside the
corresponding element and the connection lines between the voronoi points perpendicular to the
element faces in order for the solution to be numerically accurate.

Mesh example
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3 Generic definitions

Generic ways of inputting setup information is defined in this section. These definitions apply to
multiple tags in the setup files. See the tag descriptions in the module sections for information about
where the generic defintions can be used. All items etc. are zero index in FlexSem.

3.1 Initial values

Initial values can be defined as a numeric constant or by refering to a file that contains an initial
field.

<InitValue> Numeric constant value.
<InitFilename> Path and name of file with initial values. Alternative to numerical value.
<InitFileFormat> File format. ”TEXT0D”, ”TEXT1D” or ”EMB”. Mandatory for input
from file.
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<InitItemNo> Item number of item with initial values. Mandatory for input from file.

Numeric example

<InitValue >0.01</InitValue >

File example

<InitValue >

<InitFilename >sediInit.emb</InitFilename >

<InitFileFormat >EMB</InitFileFormat >

<InitItemNo >0</InitItemNo >

</InitValue >

3.2 Selecting cells

Selecting specific cells in a 3D model can be done by giving a:
• layer number
• comma separated list of layers numbers
• path and name of file with layer numbers
• comma separated list of cell numbers
• path and name of file with cell numbers
• coordinates of a polygon

<Layers> Define layer(s). ”surface”, ”bottom”, integer value or CSV list of integer values. <Lay-
ers> or <Cells> mandatory.

<Filename> Path and name of file with layer numbers.
<Cells> Define cell(s). Integer value or CSV list of integer values. Alternative to <Layers>.

<Filename> Path and name of file with cells numbers.
<Polygon> Define cells by a polygon. Alternative to ¡Filename¿.

<XCoor> CSV of polygon X coordinates.
<YCoor> CSV of polygon Y coordinates.

3.3 Passing constant values

Passing values constant in time to the model can be done by giving a:
• path and name of file with the values
• numeric
• comma separated list of numerics
• symbol of a constant (or a variable)

File example

<ConstantValues >

<Filename >MyfileWithConstantValues.txt</Filename >

</ConstantValues >

Numeric example

<ConstantValues >3.14</ConstantValues >

Comma separated example

<ConstantValues >2 ,1.4142 ,6371</ConstantValues >

Symbol example

<ConstantValues >MySymbol </ConstantValues >
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3.4 Defining a time interval

A time interval can be defined by a decimal number followed by a unit. No unit is seconds. Supported
units are:

• ’y’ : year
• ’q’ : quater
• ’m’ : month
• ’w’ :week
• ’d’ : day
• ’h’ : hour
• ’M’ : minute

3.5 Equation semantics

Equation definitions can be writting follwoing the normal math rules using symbols or numbers, e.g.
<Y = 3.14*(x+b)> If statements must be written as if(criteria,value if true, value if false). In the
criteria fortran notation must be used, i.e.

• ’<’ : .lt.
• ’≤’ : .le.
• ’>’ : .gt
• ’≥’ : .ge.

e.g. <theta nn=if(nn.gt.0,1,0)>
The following other functions are supported: exp, log, ln, abs, cos, sin, tan, tanh, max, min
The following other operators are supported: +, -, *, \

Equation example

<Equation >

<Definition >salt = if((x.lt.19).and.(d.gt.2) ,35,10)</Definition >

</Equation >

<Equation >

<Definition >flow_P_A = p_AmT*f*volmus ^(2/3) </Definition >

</Equation >

4 Modules

This sections contains a description of all FlexSem modules. All modules can run indpendent-
ly/are optional, unless otherwise stated. All date times must be given in the format ”yyyy-MM-dd
HH:mm:dd”.

4.1 General

The purpose of the general section is to define the computationel domain in time and space. Manda-
tory.

<General> Definiton of model. Mandatory.
<Mesh> Mandatory.

<Filename> Path to mesh file. Mandatory.
<Format> Format of mesh file. ”EMT” (text) or ”EMB” (binary). Mandatory.
<Projection> Projection string. ”UTM32” or ”LONLAT”. Optional, default is ”UTM32”.

<Bathymetry> Bathymetry. Mandatory.
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<Value> Bathymetry values. Numeric (constant bathymetry), comma separated values or
filename with one bathymetry value in each line.
<Filename> Bathymetry values. Filename with one bathymetry value in each line. Alterna-
tive to <Value>.

<DT> The timestep in seconds. Mandatory.
<NoTimesteps> Number of time steps. Default 0.
<NoLayers> Number of layers. Ignored if the layer thickness is given as comma seperated values.
<LayerThickness> Numeric. Sets all layers to given thickness. Mandatory.
<LayerThicknessCSV> Comma separated list of layer thicknesses (NB from bottom up). If
LayerType==”SIGMA”, the sum of the layerthicnesses must equal 1. Alternative to <Lay-
erThickness>
<OffsetTopDepth> The z axis origin. Optional. Default is 0.
<LayerType> The Layer type. ”SIGMA” (default) or ”Z”.
<StartDT> Start date and time. Default ”1970-01-01 00:00:00”.
<CheckBlowUp> Indicates if the engine should check all varaibles in each time step for blow up
values. ”True” or ”False (default).
<LogLevel> Control the logging detail level. A number between 0 and 10. Optional. Default is
0 (least logging).
<RestartFilename> Filename of .emb file containing restart information (outputted by <Out-
put><Format>RESTART</Format></Output>
<RestartTimestep> Timestep in <RestartFile> to start from.

Optionally the entire <General> section can be replaced by a reference to a file from which
the general setup will be read. This will typically be a binary output file (.emb or .nc): <Setup-
File>Myfile.emb</SetupFile>

Example

<General >

<Mesh>

<Filename >..\ OneBox.mesh</Filename >

<Format >EMT</Format >

</Mesh>

<Bathymetry >

<Filename >..\ OneBox.bathy </Filename >

</Bathymetry >

<NoLayers >1</NoLayers >

<LayerThicknessCSV >1</LayerThicknessCSV >

<LayerType >sigma </LayerType >

<StartDT >2004 -01 -01 00 :00:00 </StartDT >

<DT>3600</DT>

<NoTimesteps >10</NoTimesteps >

</General >

4.2 SpecialValues

In this section symbols for model generated variables can be defined (each creates a new variable).
These symbols can then be used as any other symbol, e.g. in an equation on in an output.

<SpecialValues>
<NoTimesteps> Symbol for the number of timesteps (=<NoTimesteps> in <General>).
<TimestepLengthSymbol> Symbol for the time step length (=<DT> in <General>).
<PISymbol> Symbol for Pi (=4*atan(1)=3.141593).
<TimestepNumberSymbol> Symbol for the time step number.
<ElementAreaSymbol> Symbol for the area all elements (2D).
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<CellDepthSymbol> Symbol for the depth of all cells (3D).
<CellVolumeSymbol> Symbol for the volume of all cells (3D).
<Bathymetry> Symbol for the bathymetry values (2D).
<BottomLayerThickness> Symbol for thethickness of the bottom layer cells (2D).
<BottomLayerMask3D> Symbol for a mask that is 1 in all bottom cells, 0 in all others (3D).
<Distance2Cell> Distance to given cell.

<Symbol> Symbol for distance (3D). Mandatory.
<CellNumber> Integer cell number to the cell from which the distances are calculated.
Mandatory.

<ElementCoordinates> Element coordiantes (cell center).
<XCoorSymbol> Symbol for the element X coordinate (2D). Mandatory.
<YCoorSymbol> Symbol for the element Y coordinate (2D). Mandatory.

<SedimentCellVolumeSymbol> Symbol for the volume of all cells in the sediment model.

Example

<SpecialValues >

<TimestepLengthSymbol >myDT</TimestepLengthSymbol >

<PISymbol >myPI</PISymbol >

<TimestepNumberSymbol >myTS</TimestepNumberSymbol >

<CellDepthSymbol >cd</CellDepthSymbol >

<CellVolumeSymbol >cv</CellVolumeSymbol >

<Distance2Cell >

<Symbol >dist2cell0 </Symbol >

<CellNumber >0</CellNumber >

</Distance2Cell >

<ElementCoordinates >

<XCoorSymbol >eXCoor </XCoorSymbol >

<YCoorSymbol >eYCoor </YCoorSymbol >

</ElementCoordinates >

</SpecialValues >

4.3 Constants

Definition of constants

<Constants>
<Constant> Optionally multiple.

<Symbol> Symbol of the constant (creates new 0D variable). Mandatory.
<Value> Numerical value of the constant. Mandatory.
<Mask> Setting up a constant mask (¡Value¿ in given cells, zero elsewhere). Optional.

<Dim> Dimension of the mask [0,1,2 or 3]. Default is 3.
<Cells> or <Layers> Define the cells that will get the value gien in <Value>. See
section 3.2. Alternative to Cells.

<Dim> 2D or 3D Constant [2 or 3]. Optional alternative to <Mask>.

Example

<Constants >

<Constant >

<Symbol >gam</Symbol >

<Value>0.8</Value >

</Constant >

<Constant >

<Symbol >PMask </Symbol >

<Value>1</Value >
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<Mask>

<Dim>3</Dim>

<Cells >

<Polygon >

<XCoor >398.7 ,651.5 ,652.3 ,398.1 </XCoor >

<YCoor >853.0 ,853.6 ,646.6 ,647.2 </YCoor >

</Polygon >

</Cells >

</Mask>

</Constant >

<Constant ><Symbol >res</Symbol ><Value >0</Value ><Dim>2</Dim></Constant >

</Constants >

4.4 Inputs

Read data from files into variables. FlexSem will automatically interpolate data from ”TEXT0D”
and ”TEXT1D” formatted files in time and space.

<Inputs>
<Input> Optionally multiple.

<Filename> Path and name of file to read data from. Mandatory.
<Format> File format. ”TEXT0D”, ”TEXT1D”, ”EMB” or ”NC”, Mandatory.
<Item> . Defines the item to read. If only one item in file, optionally leave out this tag.

<Symbol> Symbol to read data into (creates new variable). Mandatory.
<ItemNumber> Item number to read (zero based). Mandatory.
<Factor> Multiply input by this factor. Optional.

Example

<Inputs >

<Input>

<Filename >kattegatBndT_2.emb</Filename >

<Format >EMB</Format >

<ItemNumber >0</ItemNumber >

<Symbol >bnd2t </Symbol >

</Input>

<Input>

<Filename >..\ data\HBMriver4_FlexSem.txt</Filename >

<Format >TEXT0D </Format >

<Item>

<ItemNumber >0</ItemNumber >

<Symbol >src4aa </Symbol >

</Item>

<Item>

<ItemNumber >4</ItemNumber >

<Symbol >src4oo </Symbol >

</Item>

</Input >

</Inputs >

4.5 HD

The hydrodynamic (HD) module of FlexSem implements a 3D semi-implicit, finite difference-finite
volume, hydrostatic and nonhydrostatic solution to the Navier-Stokes equations on an unstructured
computational mesh as outlined by Casulli and Zanolli 2002
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Horizontal and vertical advection and diffusion of momentum is discretized using an eulerian
second order Adam-Bashford approach following Finger et al. 2006

The model includes a Smagorinsky formulation (Smagorinsky 1963) of the turbulent viscosity,
a semi-implicit advection diffusion scheme (Casulli and Zanolli 2002). Options to include clamped
open boundary forcings, surface heat budget, Coriolis forces, sources as well as bottom, vertical wall
and surface drag are also included.

The implementation is documented in Larsen et al. A versatile marine modelling tool applied to
arctic, temperate and tropical waters.. See more at http://marweb.bios.au.dk/flexsem

<HD>
<WetDry> Enable wetting and drying. Optional. Default False.
<ADType> Advection-Diffusion scheme. 2=implicit advection-diffusion scheme following Casulli
(2002), -99=No AD. Optional. Default 2.
<ImplicitnessFactor> Impliciness factor. 0.5 ¡= factor ¡=1. Default 1.
<RampupSeconds> Number of seconds to ramp up the HD model.
<FaceInterpolationRule> Type of face heigh interpolation. 0=max, 1=min, 2=mean,
3=upwind. Default if 3.
<ViscosityInterpolationType> Type of viscosity interpolation. 0=face, 1=elem mean.
Default is 1.
<NumberADSubcycles> Number of subcycles in each timestep for the AD scheme.
<Decoupled> Decoupled hydrodynamics
<InputFilename> Path and name of the file with velocities and fresh water fluxes for the
decoupling. Mandatory if Decopuled.
<InitialTemperatureValue> Initial temperature. See section 3.1
<InitialSalinityValue> Initial salinity. See section 3.1
<NonHydrostatic> Add the nonhydrostatic solution (corrector) to the hydrostatic (predictor)
HD model.
<CGTolerance> Tolerance for the Conjugate Gradient numerical solution. Default 1e-10.
<InitialWaterLevel> Initial water level. See section 3.1
<PrescripeDensitySymbol> Symbol of density. Optional, if not given density is calculated
from temperature and salinity.
<DensityCoefficient> Density coefficient. Default 1.
<DensityCalculationType> Density calculation type. 0: from S,T and P (mason.gmu.edu/ bklinger/sea-
water.pdf), 1: DensityCoefficient*S, 2: DensityCoefficient*T.
<AirPressure> Air pressure. Default not enabled.
<WindSpeedU> Wind speed u component for the surface drag.
<WindSpeedV> Wind speed v component for the surface drag.
<IceCover> Ice cover symbol. Turn off surface drag when above threshold. Optional.
<IceCoverThreshold> Ice cover threshold value. Optional. Default 0.5.
<BottomDrag> Bottom drag coefficient. Default 0.005
<AtmosphericDrag> Atmospheric drag coefficient. Default 0.
<AtmosphericDensity> Default 1.2 [kg/m3].
<VerticalWallDrag> Vertical wall drag coefficient. Default 0.005
<CoriolisF> Prescribe constant coriolis frequency. If not given it will be calculated as 2*Omega*sin(latitude)
for each face.
<SurfaceRoughnessLength> Surface roughness length.
<BottomRoughnessLength> Bottom roughness length.
<Turbulence>

<HorisontalType> Horisontal viscosity model type. <0: no turbulent viscosity (default),
0: Smagorinsky.
<VerticalType> Vertical viscosity model type. <0: no turbulent viscosity (default), 0:
k-epsilon.
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<Advect> Boolean. If true, the vertical turbulence model state parameters are advected.
Default false.
<VerticalBoundaryType> Boundary type for vertical viscosity model. 0: prescribed (Dirich-
let), 1: flux (Neumann). Default is 1.
<HorisontalDiffusivity> Horisontal diffusivity. Optional. Default 0.
<VerticalDiffusivity> Vertical diffusivity. Optional. Default 0.
<VerticalLaminarViscosity> Optional. Default 1e-4.
<HorisontalLaminarViscosity> Optional. Default 0.1.
<SmagorinskyConstant> Constant for the Smagorinsky turbulent viscosity. default 0.01.
<VerticalViscositySymbol> Symbol for the vertical viscosity.
<VerticalDiffusivitySymbol> Symbol for the vertical diffusivity.

<PhysicalBoundaries>
<PhysicalBoundary>

<Number> Mandatory. Boundary number type. Must match number in .mesh file.
<Type> Physical boundary type. ’open’: open boundary (inflow), ’waterlevel’: specify h
only, ’velocity’: specify (u,v) only, ’waterlevelandvelocity’: specify both h and (u,v).
<h> Boundary water level.
<u> Boundary velocity u component.
<v> Boundary velocity v component.

<CalculateCellCenteredVelocities> Calculate momentum conserving cell centered ve-
locities [Perot 2000]. Adds variables ’u’ and ’v’.

<USymbol> Optionally provide an alternative symbol for the cell centered east-west velocity
component.
<VSymbol> Optionally provide an alternative symbol for the cell centered north-south velocity
component.

<BottomShearStress> Calculate bottom shear stress. Adds 2D variable ’TauB’, ’u’ and ’v’

(cell centered velocities). TauB = u2
∗ρ, where ρ is the reference density and u∗ = u(z)

k ln( z
z0
),

where k is von karman constant (=0.41) and z0 is the bottom roughness length.
<Symbol> Optionally provide an alternative symbol for the 2D bottom shear stress variable.
<ReferenceDensity> Optionally provide reference density. Default is 1025 kg/m3.

Example 1

<HD>

<NonHydrostatic >false </NonHydrostatic >

<ImplicitAdvection >true</ImplicitAdvection >

<ImplicitnessFactor >0.55</ImplicitnessFactor >

<RampupSeconds >720</RampupSeconds >

<NumberADSubcycles >1</NumberADSubcycles >

<HorisontalDiffusivity >10</HorisontalDiffusivity >

<VerticalDiffusivity >0</VerticalDiffusivity >

<CGTolerance >1e-5</CGTolerance >

<VerticalLaminarViscosity >100</VerticalLaminarViscosity >

<HorisontalLaminarViscosity >0.02</HorisontalLaminarViscosity >

<ViscosityModelType >0</ViscosityModelType >

<SmagorinskyConstant >1e-8</SmagorinskyConstant >

<DensityCalculationType >0</DensityCalculationType >

<BottomDrag >0.5</BottomDrag >

<VerticalWallDrag >0.0</VerticalWallDrag >

<CoriolisF >0.0001220354 </CoriolisF > //2* Omega*sin(phi) = 2 * 7.2921e-5 *

sin (56.8/180* pi) = 0.0001220354

<CalculateCellCenteredVelocities >true</CalculateCellCenteredVelocities >

<InitialSalinityValue ><InitFilename >forcing\initts.emb</InitFilename ><

InitFileFormat >EMB</InitFileFormat ><InitItemNo >0</InitItemNo ></

InitialSalinityValue >
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<InitialTemperatureValue ><InitFilename >forcing\initts.emb</InitFilename >

<InitFileFormat >EMB</InitFileFormat ><InitItemNo >1</InitItemNo ></

InitialTemperatureValue >

<InitialWaterLevel ><InitFilename >forcing\inith.emb</InitFilename ><

InitFileFormat >EMB</InitFileFormat ><InitItemNo >0</InitItemNo ></

InitialWaterLevel >

<PhysicalBoundaries >

<PhysicalBoundary >

<Number >1</Number >

<!--<Type>WaterLevel </Type>-->

<!--<Type>Velocity </Type>-->

<Type>WaterLevelandVelocity </Type>

<u>bnd1u </u>

<v>bnd1v </v>

<w>0</w>

<h>bnd1h </h>

</PhysicalBoundary >

<PhysicalBoundary >

<Number >2</Number >

<Type>WaterLevelandVelocity </Type>

<u>bnd2u </u>

<v>bnd2v </v>

<w>0</w>

<h>bnd2h </h>

</PhysicalBoundary >

<PhysicalBoundary >

<Number >3</Number >

<Type>WaterLevelandVelocity </Type>

<u>bnd3u </u>

<v>bnd3v </v>

<w>0</w>

<h>bnd3h </h>

</PhysicalBoundary >

</PhysicalBoundaries >

<WindU>metU</WindU >

<WindV>metV</WindV >

<AtmosphericDensity >1</AtmosphericDensity >

<AtmosphericDrag >1e-8</AtmosphericDrag >

</HD>

Example 2

<HD>

<Decoupled >

<InputFilename >FSsetupVel.emb</InputFilename >

<NumberSubcycles >2</NumberSubcycles >

</Decoupled >

<HorisontalDiffusivity >0</HorisontalDiffusivity >

<VerticalDiffusivity >0</VerticalDiffusivity >

<CalculateCellCenteredVelocities >true</CalculateCellCenteredVelocities >

</HD>
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4.6 HDLite

This module contains simplified formulations of estuarine and fjord dynamics including advection,
horizontal and vertical mixing. It employs a time-dependent, combined boxmodel and 3-D model ap-
proach. Water mass exchange in the HDLite module is realized in the form of volume fluxes between
the mesh cells, formulated as an exchange volume per time unit scaled by the time step of the model.
Fluxes between mesh cells are automatically calculated from the computational mesh geometry. See
Janus Larsen, Christian Mohn, Karen Timmermann, A novel model approach to bridge the gap be-
tween box models and classic 3D models in estuarine systems, Ecological Modelling, Volume 266, 24
September 2013, Pages 19-29, ISSN 0304-3800, http://dx.doi.org/10.1016/j.ecolmodel.2013.06.030.
Alternative to <HD>

<HDLite>
<CalcDens> If true, adds variable ’dens’ and calculates density from salinity and temperature
in each timestep. ”True” or ”False”.
<InitialSaltValue> Initial value for salinity. See section 3.1
<Temperature>

<InitialValue> Initial value for water temperature. See section 3.1
<AirTemperature> Numerical value or symbol for air temperature.

<HorisontalMixing> Numeric for constant horisontal mixing. Default: 0.
<Value> Horisontal mixing coefficient. Alternative to constant horisontal mixing.
<ConstantHM> If ”True” do not scale horisontal mixing with cell volume. This makes the
horisontal mixing in each time step propotional to the area on the cell interface overlap and
there by more ’current like’ (small overlap -¿ small exchange). If ”false” the mixing scales with
the total volume of the cell. Default: ”False”.
<WindSpeedCoef> Wind dependent mixing coefficent component.
<WindSpeed> Numeric or symbol for wind speed. Mandatory if <WindSpeedCoef>.
<MaxMixDirection> Wind direction of maximum mixing coefficent.
<WindDirection> Numeric or symbol for wind direction. Mandatory if <MaxMixDirec-
tion>.

<Wind> Wind speed dependent vertical mixing. Default: No vertical mixing.
<Speed> Numeric or symbol for wind speed. Mandatory.
<AirDensity> Air density. Default: 1.293 kg/m3.
<CoriolisParameter> Coriolis parameter. Default: 0.0001.
<WaterDensity> Density of water. Default: 1000 kg/m3.
<AttenuationDepth> Attenuation depth of veritical mixing. Default: 10 m.

Example

<HDLite >

<InitialSaltValue >

<InitFilename >..\ initSalt.emb</InitFilename >

<InitItemNo >0</InitItemNo >

<InitFileFormat >EMB</InitFileFormat >

</InitialSaltValue >

<Temperature >

<InitialValue >0</InitialValue >

<AirTemperature >airtemp </AirTemperature >

</Temperature >

<HorisontalMixing >

<Value>2e-03</Value >

<WindSpeed >ws</WindSpeed >

<WindSpeedCoef >0</WindSpeedCoef >

<WindDirection >wd</WindDirection >

<MaxMixDirection > -15</MaxMixDirection >

</HorisontalMixing >
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<Wind>

<DragCoef >1e-07</DragCoef >

<AirDensity >1.293 </AirDensity >

<Speed>ws</Speed>

<CoriolisParameter >0.0001 </CoriolisParameter >

<WaterDensity >1000</WaterDensity >

<AttenuationDepth >6</AttenuationDepth >

</Wind>

</HDLite >

4.7 FlexSem

3D pelagic equation solver.

<FlexSem>
<DisableGroupCSV> Comma separated list of group names to disable. Names must match
”Group” attribute in <Variable> or <Equation>
<Variables>

<Variable> Optionally multiple. Optionally group attribute: <Equation Group="MyGroup">.
<Symbol> Variable symbol. Mandatory.
<Advect> Indicates if the variable should be advected (by HD or HDLite). ”True” or
”False” (default).
<NotNegative> Indicates if FlexSem should truncate negative values to 0. ”True” or
”False” (default).
<InitValue> Initial value for the variable. See section 3.1

<Equations>
<Equation> Optionally multiple. Optionally group attribute: <Variable Group="MyGroup">.

<Definition> Equation definition. Mandatory. See Equation semantics
<Description> Equation description. Does not affect the model.

<MappedOperation> Move a fraction of one variable in specific cells to another variable in
optionally an other set of specific cells. Used to model a patchy process moving stuff from the
pelagic to the sediment (or vica versa). Optionally multiple.

<From> Defines what to map from. Mandatory.
<Variable> Symbol of the variable to map from. Mandatory.
<Fraction> The fraction of the variable to move assuming that the variable represents
a concentration. Must be same length as the number of given cells. See section 3.3 .
Mandatory.
<Cells> Cells to map from. See section 3.2. <Layers> or <Cells> mandatory.
<Layers> Give the cells to map from as layers. See section 3.2. Alternative to Cells.

<To> Defines what to map to. Mandatory.
<Variable> Symbol of the variable to map to. Mandatory.
<Cells> Cells to map to. Length must equal <From> length. See section 3.2. <Lay-
ers> or <Cells> mandatory.
<Layers> Give the cells to map to as layers. See section 3.2. Alternative to Cells.

<DumpSystemAsRCode> Write a file with the equation system as R code.
<CellNo> Cell number to use in equation system. Mandatory.
<FileName> Path and name of file to output code to. Mandatory.

Example

<DisableGroupCSV >B</DisableGroupCSV >

<FlexSem >

<Variables >

<Variable >

<Symbol >A</Symbol >
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<Description >My A variable </Description >

<InitValue >1</InitValue >

</Variable >

<Variable Group="B">

<Symbol >B</Symbol >

<Description >My z variable </Description >

<InitValue >1</InitValue >

</Variable >

<Variable >

<Symbol >C</Symbol >

<Description >My C variable </Description >

<InitValue >0</InitValue >

</Variable >

</Variables >

<Equations >

<Equation Group="B">

<Definition >B=A*C</Definition >

<Description >Test</Description >

</Equation >

<Equation >

<MappedOperation >

<From>

<Variable >A</Variable >

<Layers >Bottom </Layers >

<Fraction >0.1</Fraction >

</From>

<To>

<Variable >C</Variable >

<Cells >Bottom </Cells >

</To>

</MappedOperation >

</Equation >

</Equations >

</FlexSem >

4.8 EcoSediment

Benthic equation solver (sediment model) including multiple layers (3D), sedimentation, diffusion.
The horisontal computation mesh is the same as the one defined in the <General> section 4.1.

<EcoSediment>
<General> Defines the

<NoLayers> Number of layers. Mandatory.
<LayerThicknessCSV> Comma separated list of layer thicknesses (NB from bottom up). If
LayerType==”SIGMA”, the sum of the layerthicnesses must equal 1. Mandatory.
<Bathymetry> Bathymetry. Mandatory.

<Value> Bathymetry values. Numeric (constant bathymetry), comma separated values or
filename with one bathymetry value in each line.
<Filename> Bathymetry values. Filename with one bathymetry value in each line. Alter-
native to <Value>.

<Run> Indicates if the sediment module modifies the valures in each time step (model on/off).
”False” or ”True” (default).

<PelagicVariables> Use values from bottom layer of a pelagic variable in all layers of the
sediment. E.g. Temperature.

<Variable> Optionally multiple.
<Symbol> Symbol of new benthic variable. Mandatory.
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<PelagicVariable> Symbol of pelagic variable to copy values from. Mandatory.
<Diffusion> Diffuse transport between bottom pelagic layer and surface benthic layer.

<DiffusionLength> The diffusion length to use. Default 0.1.
<DiffusionCoef> Default diffusion coefficient. Default 0.
<Variable> Optionally multiple.

<Symbol> Symbol of new benthic variable. Mandatory.
<InitValue> Initial value of benthic variable. If omitted, the benthic varible will inherit
the pelagic variables initial value. See section 3.1
<NotNegative> Indicates if negative values are truncated to 0. ”True” or ”False” (de-
fault).
<PelagicVariable> Symbol of existing pelagic variable to diffuse with. Mandatory.
<DiffusionCoef> Diffusion coefficient for current variable which overrides the default
diffusion coefficient.
<FluxSymbol> Add 2D variable with given symbol were the flux tranported across the
pelagic/benthich interface is stored.

<Sedimentation> Enables sedimentation/vertical advection.
<ImplicitSedimentation> Use implicit scheme for sedimentation. If false use explicit
scheme. Default true.
<PelagicVerticalVelocity> Default fall rate in the pelagic. NB positive upwards. See
section 3.3
<BenthicVerticalVelocity> Default fall rate in the sediment. NB positive upwards. See
section 3.3
<UsePelagicBottomVinTopSediment> If true, use pelagic bottom vertical velocity in top
of sediment. This causes the pelagic to sedimentate into the surface sediment layer. ”True” or
”False” (default).
<Variable> Optionally multiple.

<PelagicVerticalVelocity> Fall rate in the pelagic for this variable only (overriding
default value). NB positive upwards. See section 3.3
<BenthicVerticalVelocity> Fall rate in the sediment for this variable only (overriding
default value). NB positive upwards. See section 3.3
<Symbol> Symbol of new benthic variable. Mandatory.
<InitValue> Initial value of benthic variable. See section 3.1
<NotNegative> Indicates if negative values are truncated to 0. ”True” or ”False” (de-
fault).
<PelagicVariable> Symbol of existing pelagic variable to enable sedimentation for.
Mandatory.

<Variables> Same as for pelagic equation solver. See section 4.7.
<Equations> Same as for pelagic equation solver. See section 4.7.

Example

<EcoSediment >

<General >

<Run>true</Run>

<NoLayers >2</NoLayers >

<LayerThicknessCSV >0.5 ,0.5</LayerThicknessCSV >

<Bathymetry >

<Value >0.1</Value >

</Bathymetry >

</General >

<PelagicVariables >

<Variable >

<Symbol >botV1 </Symbol >

<PelagicVariable >V1</PelagicVariable >
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</Variable >

</PelagicVariables >

<Diffusion >

<DiffusionLength >0.1</DiffusionLength >

<DiffusionCoef >1e-5</DiffusionCoef >

<Variable >

<DiffusionCoef >1e-8</DiffusionCoef >

<Symbol >sediA </Symbol >

<InitValue >0</InitValue >

<PelagicVariable >A</PelagicVariable >

</Variable >

</Diffusion >

<Sedimentation >

<PelagicVerticalVelocity >-1e-5</PelagicVerticalVelocity >

<BenthicVerticalVelocity >-1e-7</BenthicVerticalVelocity >

<UsePelagicBottomVinTopSediment >true</UsePelagicBottomVinTopSediment

>

<Variable >

<Symbol >sediC </Symbol >

<InitValue >0</InitValue >

<PelagicVariable >C</PelagicVariable >

</Variable >

</Sedimentation >

<Variables >

<Variable >

<Symbol >sediV2 </Symbol >

<InitValue >0</InitValue >

</Variable >

</Variables >

<Equations >

<Equation >

<Definition >sediV2=botV1 -sediC </Definition >

<Description ></Description >

</Equation >

</Equations >

</EcoSediment >

4.9 Sources

Adds fresh watersources including concentrations of pelagic variables.

<Sources>
<Source> Optionally multiple.

<Symbol> Source symbol. Mandatory.
<ElemNo> Element number to add source to. Mandatory.
<Flux> Numeric or symbol that defines the fresh water flux. Mandatory for non-decoupled
sources.
<Description> Source description.
<LayerNo> Layer number to add source to. Optional CSV to destribute source over multiple
layers. Default is surface layer.
<LayerFraction> When <LayerNo> is CSV, this must be CSV of same length with frac-
tions for each layer. Optional. Default is normalized layer thicknesses.
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<VirtualFlux> Virtual flux i.e. no water is added - only concentration. Optional. Default
false.
<DynamicElementNumber> Symbol of dynamic element number, i.e. source moves in time.
Optional.
<Variable> Optionally multiple.

<Symbol> Symbol of the pelagic variable to modify. Mandatory.
<Concentration> Numeric or symbol that defines the concentration of the pelagic vari-
able in the fresh water. Mandatory.
<ConcentrationFactor> Numeric or symbol that defines a factor that the concentration
is multiplied by. Optional. Default=1.

Example

<Source >

<Symbol >s1</Symbol >

<Description >Source 1 water flux [m3/s]</Description >

<ElemNo >7</ElemNo >

<Flux>fwi</Flux>

<Variable >

<Symbol >salt</Symbol >

<Concentration >0</Concentration >

</Variable >

</Source >

<Source >

<Symbol >S1</Symbol >

<Flux>Timedistribution1 </Flux>

<ElemNo >0</ElemNo >

<LayerNo >0,1,2,3,4,5,6,7,8,9</LayerNo >

<VirtualFlux >true</VirtualFlux >

<DynamicElementNumber >S0ElemNo </DynamicElementNumber >

<Variable >

<Symbol >sediFrac1 </Symbol >

<Concentration >0.1244 </Concentration >

</Variable >

<Variable >

<Symbol >sediFrac2 </Symbol >

<Concentration >sfc2</Concentration >

</Variable >

</Source >

4.10 Boundaries

Defines open boundary conditions.

<Boundaries>
<Boundary> Optionally multiply.

<Number> Boundary number. Must match an open boundary number in the mesh. Manda-
tory.
<ExchangeRate> Numeric. Boundary exchange rate [m3/s]. HDLite only.
<WindDirection> Numeric or symbol. Modifies the exchange rate as a function of wind
direction. HDLite only.
<MaxExchangeDirection> Numeric. Direction of maximum exchange. HDLite only. Manda-
tory if <WindDirection> present.
<Variable> Optionally multiple. NB: all advected variables must be defined on all open
boundaries.

<Symbol> Symbol of the pelagic variable to modify. Mandatory.
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<Concentration> Numeric or symbol that defines the concentration of the pelagic vari-
able on the boundary. if ”upwind” values in the boundary cells are used (outflow). Manda-
tory.

Example

<Boundaries >

<WindDirection >wd</WindDirection >

<MaxExchangeDirection >0</MaxExchangeDirection >

<ExchangeRate >300</ExchangeRate >

<Boundary >

<Number >1</Number >

<Variable >

<Symbol >salt</Symbol >

<Concentration >saltbnd </Concentration >

</Variable >

<Variable >

<Symbol >temp</Symbol >

<Concentration >3.14</Concentration >

</Variable >

<Variable ><Symbol >TRC</Symbol ><Concentration >Upwind </Concentration ><

/Variable >

</Boundary >

</Boundaries >

4.11 Surface

Adds surface exchanges e.g. heat exchange, oxygen, precipitation/evaporation, or modifies other
pelagic state variables in the surface.

<Surface>
<IceCover> Ice cover symbol. Affects surface heat, oxygen and other surface exchanges. Op-
tional.
<IceType> 0: no ice, 1:turn off exchange when IceCover larger than 0, 2: scale exchanges with
iceCover. Optional. Default 0.
<HeatExchange> Optional. Add heat exchange.

<WaterTemperature> Mandatory. Numeric or symbol. Optional if <HD>, default is ’temp’
(HD temperature).
<AirTemperature> Mandatory air temperature. Numeric or symbol.

<!--Choose between Fick’s law, prescibed fluxes or heat flux model-->

<!-- Fick’s law (simple conduction)-->
<ConductivityCoefficient> Mandatory heat conduction coefficient. 10 to 100 seems to
be resonable (if 500 then water air)

<!-- Prescribed heat fluxes-->)
<ShortwaveHeatFlux> Mandatory shortwave radiation heat flux [W m-2]
<LongwaveHeatFlux> Optional longwave radiation heat flux [W m-2]. Default is 0.
<SensibleHeatFlux> Optiona lsensible heat flux [W m-2]. Default is 0.
<LatentHeatFlux> Optional latent heat flux [W m-2]. Default is 0.

<!-- Heat flux model-->)
<CloudCover> Mandatory cloud cover (0-1)
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<WindU> Mandatory wind west-east velocity
<WindV> Mandatory wind south-north velocity
<RelativeHumidity> Relative humidity. RelativeHumidity, DewPointTemperature or Speci-
ficHumidity mandatory.
<DewPointTemperature> Dew Point Temperature. Alternative to <RelativeHumidity>
<SpecificHumidity> Specific Humidity. Alternative to <RelativeHumidity>
<AirPressure> Optional air pressure [Pa]
<PenetrationDepth> Optional. Penetration depth of longwave, sensible and latent heat
fluxes. Default is 1 m.
<AddHeatFluxesAsVariables> Adds 2D variables of calculated heat fluxes: ’HeatShort-
Wave’, ’HeatLongWave’, ’HeatSensible’ and ’HeatLatent’
<WaterEmissivity> Optional. Default 0.96
<LongwaveReflectivity> Optional. Portion of atmospheric longwave radiation reflected
by water surface. Default 0.045
<WaterAlbedo> Optional. Default 0.06
<ExtinctionCoef> Optional. Default log(0.1) / 0.6=-3.837642 (90% absorbed in the top
0.6 m)
<ShortWaveExtinctionCoef> Optional. Default log(0.1) / 5.0=-0.460517 (90% absorbed
in the top 5.0 m)
<BottomReflectivity> Optional. Proportion of heat reflected in bottom. Default 1.0 (all
heat reflected back to water)
<SensibleHeatBulkCoef> Optional. Default 1.4e-3.
<EvaporationBulkCoef> Optional. Default 1.4e-3.
<MinimumWaterTemperature> Optional.

<Exchange> Optionally multiple.
<AtmosContribution> Numeric or symbol. Rate of loss/gain.
<PelagicSymbol> Symbol of pelagic variable to modify. Mandatory if <AtmosContribu-
tion> present.
<Precipitation> Numeric or symbol. Modify surface salinity by precipitation/evaporation.
<SaltSymbol> Salinity symbol. Mandatory if <Precipitation> present.

<Oxygen> Modifies surface oxygen following https://aslopubs.onlinelibrary.wiley.com/doi/10.4319/lom.2010.8.0628
<OxygenSymbol> Symbol of pelagic oxygen variable to modify. Mandatory.
<Salinity> Salinity symbol or numeric. Mandatory.
<Temperature> Water temperate symboll or numeric. Mandatory.
<WindSpeed> Wind speed symboll or numeric. Mandatory.
<UnitFactor> Oxygen saturation is calculated in ml O2/l. This is the conversion factor to
the oxygen unit that your model uses. Default 44.661 which is the conversion factor between
ml O2/l to mmol O2/m3 following ocean.ices.dk/Tools/UnitConversion.aspx.

Example

<Surface >

<IceCover >icecov </IceCover >

<IceType >2</IceType >

<HeatExchange >

<WaterTemperature >temp</WaterTemperature >

<AirTemperature >airtemp </AirTemperature >

<CloudCover >cloudcov </CloudCover >

<WindU>wu</WindU >

<WindV>wv</WindV >

<SpecificHumidity >spechum </SpecificHumidity >

<EvaporationBulkCoef >1e-4</EvaporationBulkCoef >

<AddHeatFluxesAsVariables >true</AddHeatFluxesAsVariables >

</HeatExchange >
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<MinimumWaterTemperature >-2</MinimumWaterTemperature >

<Oxygen >

<OxygenSymbol >O2</OxygenSymbol >

<Salinity >salt</Salinity >

<Temperature >temp</Temperature >

<WindSpeed >ws</WindSpeed >

<UnitFactor >44.61 </UnitFactor >

</Oxygen >

<Exchange >

<AtmosContribution >3.4e-6</AtmosContribution >

<PelagicSymbol >NO3</PelagicSymbol >

</Exchange >

<Exchange >

<Precipitation >precip </Precipitation >

<SaltSymbol >salt</SaltSymbol >

</Exchange >

</SurfaceExchanges >

4.12 EcoLight

Parameterization and calculation of light attenuation. The module adds the variable ”I” to the
model. I is calucated as I = I0*exp(-kd*d) , where d is the cell center depth, I0 = (1-k5)*v4 and kd
= k1-k2*v1+k3*v3+k4*k6*v3 This non-intuitive formulation has historic origins.

<EcoLight>
<IceCover> Ice cover symbol. Optional.
<IceType> 0: no ice, 1:turn off light when ice¿0, 2: scale light with ice cover. Optional. Default
0.
<v1> Variable symbol.
<v2> Variable symbol.
<v3> Variable symbol.
<v4> Variable symbol. Mandatory.
<k1> Numeric. Default 0.
<k2> Numeric. Default 0.
<k3> Numeric. Default 0.
<k4> Numeric. Default 0.
<k5> Numeric. Default 0.
<k6> Numeric. Default 0.
<AddkDasVariable> If ”True” adds a new variable with symbol ”kD” were kd values are stored.
<kdSymbol> Symbol for new variable were kd values are stored.

Example

<EcoLight >

<v1>salt</v1>

<v2>C</v2>

<v3>X</v3>

<v4>glorad </v4>

<k6>1</k6>

<k1>1.5</k1>

<k2>0.06</k2>

<k3>0</k3>

<k4>0.1</k4>

<k5>0.55</k5>

<kdSymbol >kd</kdSymbol >

</EcoLight >

19



4.12.1 Heat flux model

The temperature change in a cell caused by a heat flux Q is given by:

dT =
Qdt

dzρwCp
(Hodges eq. 57)

where Q is the heat flux [W m-2], dt the timestep length [s], dz the cell thickness [m], ρw the water
density [kg m-3] and Cp the heat capacity of water = 4185.5 [J K-1 kg-1]. The surface heat flux is
calculated positive downwards (negative out of the water) ans is given by:

Q = Qs +Ql +QH +QL

where Qs is the short wave radiation heat flux, Ql the long wave heat radiation heat flux, QH the
sensible heat flux and AL the latent heat flux.

The long wave radation heat flux is given by:

Ql = −ϵwσT
4
w + ϵaσT

4
a (1−Rtlw)(1 + 0.7C2

cloud) (Hodges eq. 4)

where Tw is the water temperature in Kelvin [K], Ta is the air temperature in Kelvin [K], ϵw the
emissivity of water], ϵa the emissivity of air = 0.920 ∗ 10−5T 2

a , σ is Stefan-Boltzmans constant =
5.669*10-8 W m-2 K-4, Rtlw the total reflectivity of the water surface1 and Ccloud the fractional cloud
cover.

The sensible heat flux is given by:

QH = ρaCpaCHUwind(Ta − Tw) (Hodges eq. 29)

where ρa is the air density =1.2 kg m-3, Cpa the specific heat capacity of air = 1003 J kg-1 K-1, CH

the bulk transfer coefficient for sensible heat = 1.4*10-3 and Uwind the wind speed in m s-1

The latent heat flux is given by:

QL = LCWUwindρa(qa − qw) (Hodges eq. 22)

where L is the latent heat of evaporation = 2.453*106 J Kg-1, CW the bulk transfer coefficient for
evaporation = 1.4*10-3, qa the specific humidity in air and qs the saturation humidity.

qs =
0.622

Pa
es (Hodges eq. 24)

where Pis the air pressure [pa] and es, the saturation vapor pressure2:

es = exp(log(611.2) +
17.62 ∗ Ta

243.12 + Ta
) (1)

qa =
0.622es

Pa
Rh (2)

where Rh is the relative humidity:

Rh =
e

es
(3)

1[Hodges 1998] uses 0.3, but others e.g. Josley et al 1997 https://agupubs.onlinelibrary.wiley.com/doi/pdf/10.1029/97JC02420
uses much smaller numbers: 0.045, which is default in FlexSem

2from www.npl.co.uk/reference/faqs/how-do-i-convert-between-units-of-dew-point-and-relative-humidity-(faq-
thermal)
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where e is the vapor pressure. If the dew point temperature is given instead of the relative humidity,
the specific humidity can be calculated by using the dew point temperature in equation ?? to find
the vapor pressure e and then calculating the specific humidity by:

qa =
0.622

Pa
e (4)

The sum of the heatfluxes from long wave radiation, sensible and latent heat is absorbed exponentially
decreasing by depth until the penetration depth is reached. If the water is shallower than the
penetration depth, the heat is reflected in the bottom and the remaining heat equally distributed in
the water column. See Hodges 1998 for a detailed description.

The short wave radation heat flux is given by:

Qs = Qswsurf (1− 0.65C2
cloud)(1−Rtsw) (Hodges eq. 42)

where Qswsurf is the clear sky incomming surface radiation and Rtsw the short wave surface reflectivity
( albedo).

Qswsurf = 0.75
S0

d2
cos(θ) (Sun eq. 7)

where S0 is the solar constant = 1367 W m-2, d the earth-sun distance in astronomical units and θ
the solar zenit angle.

d = 1 + 0.0167sin(2π
DOY − 93.5

365
) (Sun eq. 3)

where DOY is the day of year. The solar zenit angle is determined by:

cos(θ) = sin(δ)sin(φ) + cos(δ)cos(φ)cos(ω) (Sun eq. 4b)

where φ the latitude, ω the solar hour angle = π t−12
12 , t = local time in hours and δ is the solar

declination:

δ = 0.4093sin(2π
DOY + 284

365
) (Sun eq. 4b)

Like the other heat fluxes, the short wave radiation heat flux is also absorbed exponentially decreas-
ing by depth until the penetration depth is reached. However the penetration depth is typically
greater (∼ the secchi disk depth). If the bottom is reached the remaining flux is reflacted and ab-
sorbed exponentially decreasing upwards toward the surface. If the surface is reached before all the
heat is absorbed, the remaining is equally distributed in the water column. See Hodges 1998 for a
detailed description.

References:

Ben Hodges 1998 Heat budget and thermodynamics at a free surface: some theory and
numerical implementation (revision 1.0c) ED 1300 BH
Sun, Zhigang; Gebremichael, Mekonnen; Wang, Qinxue; Wang, Junming; Sammis, Ted
W.; Nickless, Alecia. 2013. ”Evaluation of Clear-Sky Incoming Radiation Estimating
Equations Typically Used in Remote Sensing Evapotranspiration Algorithms.” Remote
Sens. 5, no. 10: 4735-4752.

4.13 Sections

Calculate fluxes through user defined vertical sections. The flux is calculated positively to the right
when walking along the section in the order that the nodes numbers are given.
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<Sections>
<Section> Define new section to calculate flux through. Optionally multiple.

<NodeNumberCSV> Comma separated list of node numbers that defines the section. The
node numbers must be connected by a face.
<StartNode> Start node of section. Alternative to <NodeNumberCSV>
<EndNode> End node of section. Shortest path (Dijkstra) between <StartNode> and
<EndNode> will be used. Mandatory if <StartNode>.
<FluxCalc> Calculate flux of specific variable through the section. Optionally multiple.

<PelagicSymbol> Symbol of pelagic variable to calculate flux for. Mandatory.
<Symbol> Symbol of new 0D variable to hold result of flux calculation. Mandatory if not
<BruttoPositiveFluxSymbol> and <BruttoNegativeFluxSymbol>.
<BruttoPositiveFluxSymbol> Symbol of new 0D variable to hold postive part of flux
calculation. Optional alternative to <Symbol>
<BruttoNegativeFluxSymbol> Symbol of new 0D variable to hold negative part of flux
calculation. Optional alternative to <Symbol>

Example

<Sections >

<Section >

<NodeNumberCSV >142 ,300 ,264 ,41</NodeNumberCSV >

<FluxCalc >

<Symbol >saltflux </Symbol >

<PelagicSymbol >salt</PelagicSymbol >

</FluxCalc >

</Section >

<Section >

<StartNode >1200</StartNode >

<EndNode >1042</EndNode >

<FluxCalc >

<Symbol >NFlux1 </Symbol >

<PelagicSymbol >TN</PelagicSymbol >

<BruttoPositiveFluxSymbol >NFlux1Pos </BruttoPositiveFluxSymbol >

<BruttoNegativeFluxSymbol >NFlux1Neg </BruttoNegativeFluxSymbol >

</FluxCalc >

</Section >

</Sections >

4.14 AgentBasedModel

Add agent based model (ABM). Agents can have a model system which will be solved for each agent
and can be advected in a Lagrangian way in the model.

<AgentBasedModel>
<Agents> Add agents for model. Mandatory.

<MaxNumberAgents> Set the maximum number of agents in the model. Optional. default
is the initial number of agents.
<Depth> Default initial depth for the agents. Optional. Default is 0.
<OneInEachElementCenter> Add one agent in each element center.
<ActivateTimestep> Timestep or datetime when the agents will be activated. Optional.
Default 0.
<GridDx>
<GridDy>Add agents in a grid given by ¡GridDx¿ and ¡GridDy¿. Alternative to ¡OneInEachEle-
mentCenter¿
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<Filename> Add agents from a text file with the columns x,y and optionally z coordinates.
Alternative to grid.

<MaxNumberAgents> MaxNumberAgents. Optional. Default is number of initial agents.
<IgnoreInitAgentsOutsideMesh> If true agents with initial positions outside mesh will be
ignored. Optional. Default false.
<RandomSpeed> Agent velocities will be added with a random number between 0 and this value.
Optional. Default 0.
<TimestepInterval> Integer interval of timesteps at which the agent bsae model is runned.
(so 1 means every timestep).
<ABMDTSymbol> The symbol assigned to the ABM timestep length (dt*<TimestepInterval>).
Optional. If not given no variables will be created.
<Variables> Same as for pelagic equation solver. See section 4.7.
<Equations> Same as for pelagic equation solver. See section 4.7.
<AgentPerElementSymbol> Sum up the number of agents per element in this 2D variable.
Optional.
<AgentPerCellSymbol> Sum up the number of agents per cell in this 3D variable. Optional.
<Boundaries>

<AllClosed> Make open boundaries behave like land boundaries (agents do not leave the
domain).

<AgentDeactivateCriterion> Equation which can be evaluated as a boolean. Deactivate
agents when true. Deactivated agents still exist, but their properties

Example

<AgentBasedModel >

<TimestepInterval >1</TimestepInterval >

<Agents >

<Depth >0</Depth >

<GridDx >0.005 </GridDx >

<GridDy >0.005 </GridDy >

</Agents >

<ABMDTSymbol >abmdt </ABMDTSymbol >

<RandomSpeed >0.001 </RandomSpeed >

<Variables >

<Variable >

<Symbol >age</Symbol >

<InitValue >0</InitValue >

</Variable >

</Variables >

<Equations >

<Equation >

<Definition >age = age + abmdt </Definition >

</Equation >

</Equations >

<AgentDeactivateCriterion >age.gt .72000 </AgentDeactivateCriterion >

<AgentPerElementSymbol >abmPE </AgentPerElementSymbol >

<AgentPerCellSymbol >abmPC </AgentPerCellSymbol >

</AgentBasedModel >
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4.15 Outputs

Output variable values to files. Each file can only contain variable of the same dimenstion, i.e. you
cannot output e.g. 2D and 3D variables to the same file.

<Outputs>
<InputDTEqualsOutputDT> If true initial values are not outputted. Optional. Default false.
<OutputFolder> All output Filenames will be concatenated with this string. Optional. Default
empty string.
<Output> New output. Optionally multiple.

<Filename> Output filename. Mandatory.
<Format> Format of output file. ”EMT” (tab separated), ”EMF” (fixed width), ”EMB”
(native binary), ”NC (NetCdf), ”RESTART” (output restart file), ”DECOUPLED” (output
decoupled file). Mandatory.
<TimestepFrom> The first time step to output. Default 0.
<TimestepTo> The last time step to output. Default is all time steps.
<TimestepInterval> The interval between outputted time steps. Default 1.
<Interval> The time between outputted time steps, see 3.4. Alternative to <TimestepIn-
terval>
<CellNoCSV> Integer array of cell number to output. Default is to output all cells.
<BoundaryNumber> Output boundary file for this boundary number.
<FixedWidthFieldWidth> Width of the fields in fixed width format. Default 12.
<MaxFilesize> Maximum file size. If output is larger, the files are automatically split into
multiple files. E.g. ”1.9Gb”
<Variable> The symbol of the variable to output. Optionally multiple. Optional average
attribute: <Variable Average="True"> to average values over <TimestepInterval>
timesteps. Optional attribute: <Variable WaterColumnIntegration="True"> to in-
tegrate varaible over water column (Coverts 3D variable to 2D variable.

Example

</Outputs >

<Output >

<Filename >InOutAvg.txt</Filename >

<TimestepFrom >0</TimestepFrom >

<TimestepTo >-1</TimestepTo >

<TimestepInterval >4</TimestepInterval >

<Format >EMF</Format >

<FixedWidthFieldWidth >14</FixedWidthFieldWidth >

<Variable Average="true">ws</Variable >

<Variable >ws</Variable >

<Variable >wd</Variable >

</Output >

<Output >

<Filename >LaholmsbuktenVelOneDay3D.emb</Filename >

<Format >EMB</Format >

<Variable >TRC</Variable >

</Output >

<Output >

<Filename >LaholmsbuktenVelOneDay2D.emb</Filename >

<Format >EMB</Format >

<Variable >h</Variable >

</Output >

</Outputs >
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